[Vtigercrm-developers] vtiger compatibility with php 7.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Vtigercrm-developers] vtiger compatibility with php 7.1

Ruben Estrada
Hi,

I was wondering whether Vtiger is compatible with php 7.1. I couldn't find an official source about compatibility, so I tested it out.

My conclusion: it's NOT. As an example, if you try drag n drop of events in calendar view, it won't work because of php 7.1. Switching to php 7.0 or 5.6 fixes the problem.

anybody knows if compatibility with php 7.1 is planned  for the near future?

_______________________________________________
http://www.vtiger.com/
Rubén Estrada
simplesistemas.com
Reply | Threaded
Open this post in threaded view
|

Re: vtiger compatibility with php 7.1

Sutharsan Jeganathan
Hi Ruben

Vtiger supports up to  PHP 7.0.x.  Even php 7.1 active support already ended and security updates will be ended within this year as per https://www.php.net/supported-versions.php

So it would be better to upgrade to PHP 7.3.   At the moment vtiger has problems such as using empty [] to arrays.  We are looking for a chance to upgrade it for a client. If that will happen i will  update.  You can find more in php 7.1 change log


Thanks
Sutharsan Jeanathan


On Tue, Aug 20, 2019 at 9:01 AM Rubén A. Estrada Orozco <[hidden email]> wrote:
Hi,

I was wondering whether Vtiger is compatible with php 7.1. I couldn't find an official source about compatibility, so I tested it out.

My conclusion: it's NOT. As an example, if you try drag n drop of events in calendar view, it won't work because of php 7.1. Switching to php 7.0 or 5.6 fixes the problem.

anybody knows if compatibility with php 7.1 is planned  for the near future?
_______________________________________________
http://www.vtiger.com/


--
Development Manager
Radus28 Software Solution

123, Level 2, Mc Larens Building
Baudhaloka Mw.
Colombo 04
Sri Lanka
M : +94773795291
E  : [hidden email]
W : www.radus28.com

_______________________________________________
http://www.vtiger.com/

logo_web.png (20K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: vtiger compatibility with php 7.1

Ruben Estrada
Hi Sutharsan,

That's exactly the issue I found (the use of []).

It would be nice to have 7.3 compatibility

On Tue, Aug 20, 2019, 3:07 AM Sutharsan J <[hidden email]> wrote:
Hi Ruben

Vtiger supports up to  PHP 7.0.x.  Even php 7.1 active support already ended and security updates will be ended within this year as per https://www.php.net/supported-versions.php

So it would be better to upgrade to PHP 7.3.   At the moment vtiger has problems such as using empty [] to arrays.  We are looking for a chance to upgrade it for a client. If that will happen i will  update.  You can find more in php 7.1 change log


Thanks
Sutharsan Jeanathan


On Tue, Aug 20, 2019 at 9:01 AM Rubén A. Estrada Orozco <[hidden email]> wrote:
Hi,

I was wondering whether Vtiger is compatible with php 7.1. I couldn't find an official source about compatibility, so I tested it out.

My conclusion: it's NOT. As an example, if you try drag n drop of events in calendar view, it won't work because of php 7.1. Switching to php 7.0 or 5.6 fixes the problem.

anybody knows if compatibility with php 7.1 is planned  for the near future?
_______________________________________________
http://www.vtiger.com/


--
Development Manager
Radus28 Software Solution
Radus28 Software Solution
123, Level 2, Mc Larens Building
Baudhaloka Mw.
Colombo 04
Sri Lanka
M : +94773795291
E  : [hidden email]
W : www.radus28.com
_______________________________________________
http://www.vtiger.com/

_______________________________________________
http://www.vtiger.com/
Rubén Estrada
simplesistemas.com
Reply | Threaded
Open this post in threaded view
|

Re: vtiger compatibility with php 7.1

Prasad-14
I use PHP 7.2.19 - is there any breaking changes with PHP 7.3?
--
FB I Twit I LIn I Blog I Website


On Tue, Aug 20, 2019 at 6:50 PM Rubén A. Estrada Orozco <[hidden email]> wrote:
Hi Sutharsan,

That's exactly the issue I found (the use of []).

It would be nice to have 7.3 compatibility

On Tue, Aug 20, 2019, 3:07 AM Sutharsan J <[hidden email]> wrote:
Hi Ruben

Vtiger supports up to  PHP 7.0.x.  Even php 7.1 active support already ended and security updates will be ended within this year as per https://www.php.net/supported-versions.php

So it would be better to upgrade to PHP 7.3.   At the moment vtiger has problems such as using empty [] to arrays.  We are looking for a chance to upgrade it for a client. If that will happen i will  update.  You can find more in php 7.1 change log


Thanks
Sutharsan Jeanathan


On Tue, Aug 20, 2019 at 9:01 AM Rubén A. Estrada Orozco <[hidden email]> wrote:
Hi,

I was wondering whether Vtiger is compatible with php 7.1. I couldn't find an official source about compatibility, so I tested it out.

My conclusion: it's NOT. As an example, if you try drag n drop of events in calendar view, it won't work because of php 7.1. Switching to php 7.0 or 5.6 fixes the problem.

anybody knows if compatibility with php 7.1 is planned  for the near future?
_______________________________________________
http://www.vtiger.com/


--
Development Manager
Radus28 Software Solution
Radus28 Software Solution
123, Level 2, Mc Larens Building
Baudhaloka Mw.
Colombo 04
Sri Lanka
M : +94773795291
E  : [hidden email]
W : www.radus28.com
_______________________________________________
http://www.vtiger.com/
_______________________________________________
http://www.vtiger.com/

_______________________________________________
http://www.vtiger.com/