[Vtigercrm-developers] vtiger 7.0 report multiple issues: customize report not working for non admin users, button missing for shared reports and cannot un-share a shared report

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Vtigercrm-developers] vtiger 7.0 report multiple issues: customize report not working for non admin users, button missing for shared reports and cannot un-share a shared report

lounik
Hi,

I've found another couple of bugs I wondered whether I'm the only one
experiencing this.

1. CUSTOMIZE REPORT

customize reports don't work for non-admin users. If non-admin user
clicks on it, the user can go all the procedure until the save and
generate button but after clicking the save and generate button, the
users get a json response with success false and permission denied

2. CUSTOMIZE REPORT BUTTON MISSING

An admin user shares a report and click on save and generate to create
the report. At this point the admin user sees no change but the
non-admin users have no customize button anymore

3. CANNOT UN-SHARE REPORT

An admin user creates a shared report. Later he decides to remove
everything from the sharing options so he goes to customize report,
removes the sharing values, click on save and generate to save the
changes but the changes are not saved: if the admin user click again on
customize report, the sharing values are still there. If the admin user
modify the sharing values, the new values get saved but he cannot remove
all the options entirely.

Any help on these?


_______________________________________________
http://www.vtiger.com/
Reply | Threaded
Open this post in threaded view
|

Re: vtiger 7.0 report multiple issues: customize report not working for non admin users, button missing for shared reports and cannot un-share a shared report

Alan Lord (News)
The vtiger Report engine has been bit of a PITA for years ;-)

I have found a few bugs with the 7.1 Report UI recently and reported
these on Gitlab.

http://code.vtiger.com/vtiger/vtigercrm/issues/1075
http://code.vtiger.com/vtiger/vtigercrm/issues/1076
http://code.vtiger.com/vtiger/vtigercrm/issues/1077

And there are some older ones too:

http://code.vtiger.com/vtiger/vtigercrm/issues/1065
http://code.vtiger.com/vtiger/vtigercrm/issues/966

I am not familiar with the issues you mention but would suggest
recording them on Gitlab with clear instructions about how to reproduce
the problem.

Cheers

Al


On 09/01/2019 14:47, lucia digirolamo wrote:

> Hi,
>
> I've found another couple of bugs I wondered whether I'm the only one
> experiencing this.
>
> 1. CUSTOMIZE REPORT
>
> customize reports don't work for non-admin users. If non-admin user
> clicks on it, the user can go all the procedure until the save and
> generate button but after clicking the save and generate button, the
> users get a json response with success false and permission denied
>
> 2. CUSTOMIZE REPORT BUTTON MISSING
>
> An admin user shares a report and click on save and generate to create
> the report. At this point the admin user sees no change but the
> non-admin users have no customize button anymore
>
> 3. CANNOT UN-SHARE REPORT
>
> An admin user creates a shared report. Later he decides to remove
> everything from the sharing options so he goes to customize report,
> removes the sharing values, click on save and generate to save the
> changes but the changes are not saved: if the admin user click again on
> customize report, the sharing values are still there. If the admin user
> modify the sharing values, the new values get saved but he cannot remove
> all the options entirely.
>
> Any help on these?
>
>
> _______________________________________________
> http://www.vtiger.com/
>


_______________________________________________
http://www.vtiger.com/