[Vtigercrm-developers] unlink not working

classic Classic list List threaded Threaded
6 messages Options
nab
Reply | Threaded
Open this post in threaded view
|

[Vtigercrm-developers] unlink not working

nab
Hello,
In the version 7 of vtiger, when i try to dissociate a contact from a
project, the unlink button does not work, same thing happen with other
modules, is it a bug? do you have any suggestions?
Nb



--
Sent from: http://vtiger-crm.2324883.n4.nabble.com/vtigercrm-developers-f4.html
_______________________________________________
http://www.vtiger.com/
nab
Reply | Threaded
Open this post in threaded view
|

Re: unlink not working

nab
Any suggestions?
Thanks!
Nb



--
Sent from: http://vtiger-crm.2324883.n4.nabble.com/vtigercrm-developers-f4.html
_______________________________________________
http://www.vtiger.com/
Reply | Threaded
Open this post in threaded view
|

Re: unlink not working

Alan Lord (News)
In reply to this post by nab
You do not say specifically what version of vtiger you are referring
too. However if you search *all* issues (including those which are
closed) in code.vtiger.com there are several which mention unlink.

The one closest to the description of your problem would seem to be this:

http://code.vtiger.com/vtiger/vtigercrm/issues/699

First I would check if your version is vtiger is after this commit...

HTH

Al


On 12/03/2019 19:26, nab wrote:

> Hello,
> In the version 7 of vtiger, when i try to dissociate a contact from a
> project, the unlink button does not work, same thing happen with other
> modules, is it a bug? do you have any suggestions?
> Nb
>
>
>
> --
> Sent from: http://vtiger-crm.2324883.n4.nabble.com/vtigercrm-developers-f4.html
> _______________________________________________
> http://www.vtiger.com/
>


_______________________________________________
http://www.vtiger.com/
nab
Reply | Threaded
Open this post in threaded view
|

Re: unlink not working

nab
Thank's Alan,
I think my issue is a little bit different, the version is "7.1.0".
To clarify, I added two screenshots, the first one illustrates the way to
unlink a contact using the button
<http://vtiger-crm.2324883.n4.nabble.com/file/t1609/unlink_button.png> .
"Project" represents a principal module and "Contacts" represents the
related module. In this case, the deletion does not work.
The second illustrates the way to delete a contact using the "Delete
Contacts" button when on the contact detail. In this case, the deletion
works perfectly.

<http://vtiger-crm.2324883.n4.nabble.com/file/t1609/relatedmodulecontact.png>

<http://vtiger-crm.2324883.n4.nabble.com/file/t1609/detailContact.png>

Nb



--
Sent from: http://vtiger-crm.2324883.n4.nabble.com/vtigercrm-developers-f4.html
_______________________________________________
http://www.vtiger.com/
Reply | Threaded
Open this post in threaded view
|

Re: unlink not working

Alan Lord (News)
So now we know a bit more about the nature of the problem, when you try
to unlink, with error reporting enabled, debug logging enabled and with
your browser's javascript console active, what errors are reported when
you click the unlink button? And what is recorded in the debug log?

Maybe we can help you more then.

Alan


On 14/03/2019 14:11, nab wrote:

> Thank's Alan,
> I think my issue is a little bit different, the version is "7.1.0".
> To clarify, I added two screenshots, the first one illustrates the way to
> unlink a contact using the button
> <http://vtiger-crm.2324883.n4.nabble.com/file/t1609/unlink_button.png> .
> "Project" represents a principal module and "Contacts" represents the
> related module. In this case, the deletion does not work.
> The second illustrates the way to delete a contact using the "Delete
> Contacts" button when on the contact detail. In this case, the deletion
> works perfectly.
>
> <http://vtiger-crm.2324883.n4.nabble.com/file/t1609/relatedmodulecontact.png>
>
> <http://vtiger-crm.2324883.n4.nabble.com/file/t1609/detailContact.png>




_______________________________________________
http://www.vtiger.com/
nab
Reply | Threaded
Open this post in threaded view
|

Re: unlink not working

nab
Hi alan
I did not notice any error in the browser's JavaScript console or any
inconsistency in the debug log by clicking on the Unlink button.
It seems that the system does not react when we want to confirm the
deletion.
However, the unlink button works in the case of the relatedmodules tasks or
documents, but not in the case of the relatedmodule contact or a custom
relatedmodule.
Nb



--
Sent from: http://vtiger-crm.2324883.n4.nabble.com/vtigercrm-developers-f4.html
_______________________________________________
http://www.vtiger.com/