[Vtigercrm-developers] Setting "From Email" in Workflow Email Task?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Vtigercrm-developers] Setting "From Email" in Workflow Email Task?

Alan Lord (News)
I have a customer in the USA which wants to send an email from a
workflow (they are using vtiger 6.3.0).

When they enter:

> Pretty Name<[hidden email]>

in the From field and save the task, the email portion is removed from
the Task in the database:

> s:9:"fromEmail";s:21:"Pretty Name";s2...

If I use an email from the dropdown to the right of the From field, e.g.

> $(general : (__VtigerMeta__) supportName)<$(general : (__VtigerMeta__) supportEmailId)>

Then it is saved correctly in the Task in the database

> s:9:"fromEmail";s:93:"$(general : (__VtigerMeta__) supportName)&lt;$(general : (__VtigerMeta__) supportEmailId)&gt;";s:2...

If I add a "$" after the "<" then the data is saved in the Task in the
database properly:

> s:9:"fromEmail";s:67:"Pretty Names&lt;$[hidden email]&gt;";s:2

But obviously the email address is now wrong as it has a $ in front of
it. So when an email is added to the com_vtiger_workflowtask_queue the
fromEmail is:

$[hidden email] and the fromName is correct.


Can someone tell me where this save action for the Email Task is being
processed so I can fix it? I can't find it! Or, was this fixed in a
later version and can I simply replace a file or two?

TIA

Al

_______________________________________________
http://www.vtiger.com/