[Vtigercrm-developers] ModTracker not working on custom module

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Vtigercrm-developers] ModTracker not working on custom module

Ruben Estrada
Hi,

I was working on a custom module today.

When I went to the updates section I noticed this:

image.png

It says the record was created 49 years ago (beginning of unix time).

when hovering over the "49 years ago" label I get the correct created time.

The created and modified times on the record look like this:
image.png


When looking at the vtiger_modtracker_basic table, it looks like this for the module:
image.png

NULL is being stored on the changedon column. 

For vtiger standard modules it looks like this:

image.png

I was looking at ModTrackerHandler.php but couldn't figure out why it's happening:

image.png

Any clue as to why this is happening?

thanks!

Saludos

Rubén

_______________________________________________
http://www.vtiger.com/
Rubén Estrada
simplesistemas.com
Reply | Threaded
Open this post in threaded view
|

Re: ModTracker not working on custom module

Alan Lord (News)
On 17/09/2019 03:07, Rubén A. Estrada Orozco wrote:
>  
> NULL is being stored on the changedon column.

I've seen this before in upgraded systems. I "think" it was a failure
due to the modifiedtime columns being spelled incorrectly in
vtiger_field, ModifiedTime, rather than modifiedtime (How it was
originally declared in the very early vtlib documentation), or it might
have been the typeofdata being "D" not "DT".

HTH

Al

_______________________________________________
http://www.vtiger.com/
Reply | Threaded
Open this post in threaded view
|

Re: ModTracker not working on custom module

Alan Lord (News)
Also check spelling of CreatedTime fields too; Should be createdtime.

Al

On 17/09/2019 08:04, Alan Lord wrote:

> On 17/09/2019 03:07, Rubén A. Estrada Orozco wrote:
>>
>> NULL is being stored on the changedon column.
>
> I've seen this before in upgraded systems. I "think" it was a failure
> due to the modifiedtime columns being spelled incorrectly in
> vtiger_field, ModifiedTime, rather than modifiedtime (How it was
> originally declared in the very early vtlib documentation), or it might
> have been the typeofdata being "D" not "DT".
>
> HTH
>
> Al
>
> _______________________________________________
> http://www.vtiger.com/


_______________________________________________
http://www.vtiger.com/
Reply | Threaded
Open this post in threaded view
|

Re: ModTracker not working on custom module

Ruben Estrada
Your are great Alan! Solved :)


Saludos

Rubén


On Tue, Sep 17, 2019 at 2:11 AM Alan Lord <[hidden email]> wrote:
Also check spelling of CreatedTime fields too; Should be createdtime.

Al

On 17/09/2019 08:04, Alan Lord wrote:
> On 17/09/2019 03:07, Rubén A. Estrada Orozco wrote:
>>
>> NULL is being stored on the changedon column.
>
> I've seen this before in upgraded systems. I "think" it was a failure
> due to the modifiedtime columns being spelled incorrectly in
> vtiger_field, ModifiedTime, rather than modifiedtime (How it was
> originally declared in the very early vtlib documentation), or it might
> have been the typeofdata being "D" not "DT".
>
> HTH
>
> Al
>
> _______________________________________________
> http://www.vtiger.com/


_______________________________________________
http://www.vtiger.com/

_______________________________________________
http://www.vtiger.com/
Rubén Estrada
simplesistemas.com
Reply | Threaded
Open this post in threaded view
|

Re: ModTracker not working on custom module

Alan Lord (News)
On 17/09/2019 20:10, Rubén A. Estrada Orozco wrote:
> Your are great Alan! Solved :)

Awww - thanks :-)


_______________________________________________
http://www.vtiger.com/